Beta
×

Welcome to the Slashdot Beta site -- learn more here. Use the link in the footer or click here to return to the Classic version of Slashdot.

Thank you!

Before you choose to head back to the Classic look of the site, we'd appreciate it if you share your thoughts on the Beta; your feedback is what drives our ongoing development.

Beta is different and we value you taking the time to try it out. Please take a look at the changes we've made in Beta and  learn more about it. Thanks for reading, and for making the site better!

Updates to Journal System

CmdrTaco (1) writes | about 5 years ago

User Journal 13

We've made some significant updates to the submission/journal system. Visiting Submissions and Journals yields a new form that allows stuff like tags to the data types. There are a number of annoying bugs, but for the most part the dust is starting to settle. More notes will be coming, but this journal entry is really just me putting the final test on the new Journal form.

We've made some significant updates to the submission/journal system. Visiting Submissions and Journals yields a new form that allows stuff like tags to the data types. There are a number of annoying bugs, but for the most part the dust is starting to settle. More notes will be coming, but this journal entry is really just me putting the final test on the new Journal form.

cancel ×

13 comments

Sorry! There are no comments related to the filter you selected.

Hmm (1)

Captain Splendid (673276) | about 5 years ago | (#29466393)

How about this [slashdot.org] particular resource? Going to be phased out eventually?

Re:Hmm (2)

CmdrTaco (1) | about 5 years ago | (#29466949)

you would go to /journal instead. It's just there to make sure while we worked out kinks.

Subject icon? (1)

johndiii (229824) | about 5 years ago | (#29467007)

Will there be the ability to apply a subject icon to a journal entry, as in the past? I rather liked that, though I only used a few different ones.

I assume that checking the "Publicize Your Journal..." box is equivalent to the old "Publicize" option, and that leaving it unchecked equates to the old "Post" option (meaning that the old "Publish" option goes away).

The vertical dimension of the text entry box on the new form is rather small. I altered the default size of the text edit box for journal entries, so that it would show more lines. Will I be able to do that with the new form?

Re:Subject icon? (2)

CmdrTaco (1) | about 5 years ago | (#29467447)

the icon will be back. it's broken and missing.

you are correct about publicice/post. The old options were confusing and barely used.

I didn't even think about respecting that user preference. I'll put that in the list.

how about fixing the firehose bug? (1)

damn_registrars (1103043) | about 5 years ago | (#29468417)

I've mentioned this bug in my journal entries a few times, but the last time I used the firehose it was still there.

The bug I refer to works as follows:
  • Go to the firehose
  • Click the slashdot logo at the top left (which should take you back to the main slashdot.org page)
  • Front page is now rendered as the firehose, rather than the "normal" front page

From my observation, the only way to get back to the normal slashdot front page after viewing the firehose is to type slashdot.org into your browser. This behavior is present on multiple OS/Browser combinations.

Re:how about fixing the firehose bug? (2)

CmdrTaco (1) | about 5 years ago | (#29468781)

When you say "Go to the firehose" what URL exactly are you looking at? (technically, many pages on slashdot are generated by the firehose). Including the index..

Re:how about fixing the firehose bug? (1)

damn_registrars (1103043) | about 5 years ago | (#29469389)

When you say "Go to the firehose" what URL exactly are you looking at?

In particular slashdot.org/firehose.pl [slashdot.org]

After I load that page, I can't get the front page to load without the firehose decorations around it (+/- for stories, color-coded search at top-right), unless I manually type in slashdot.org to the address bar in my browser.

I also see that the front page that I should see when I click the top-left link shows up with an url of slashdot.org/firehose.pl in my browser, even though hovering over the logo indicates an url of just slashdot.org

Re:how about fixing the firehose bug? (2)

CmdrTaco (1) | about 5 years ago | (#29469595)

well, first off, don't use firehose.pl. use /recent or /popular (depending on your preference).

did you happen to use the left hand custom section menu to make a different section your default section? If so, you will land there when you click the logo.

Re:how about fixing the firehose bug? (1)

damn_registrars (1103043) | about 5 years ago | (#29469921)

well, first off, don't use firehose.pl. use /recent or /popular

I didn't know I wasn't supposed to use firehose.pl. However, when I get the link on the front page "you are invited to take a drink from the firehose", it points to firehose.pl.

Where should that link send me instead? I tried /recent and /popular and on my current browser setup they both look like the regular front page.

did you happen to use the left hand custom section menu to make a different section your default section? If so, you will land there when you click the logo.

I don't recall having ever looked at such a menu, so I would guess that I have not.

Re:how about fixing the firehose bug? (2)

CmdrTaco (1) | about 5 years ago | (#29470621)

We'll update that message. Forgot about that.

I don't know what to say about that corner logo: I redirect to my default slashdot filter. But I'll look into it and see what's up. I know there are some issues with like foo.slashdot.org and the logo on those pages linking to slashdot.org vs foo.slashdot.org, as well as proper mechanisms for navigating back and forth, but I thought it was mostly logical.

Re:how about fixing the firehose bug? (1)

Qzukk (229616) | about 5 years ago | (#29470953)

When I'm on the firehose, the logo has

onclick="firehose_set_options('section','13');"

I presume this is what he's talking about. Without that onclick, it would load the main page, which for me is nearly identical except for two things:

1) The article title is a URL pointing to that article on the index. On the firehose, the firehose_set_options() javascript (and the automatic update javascript) sets the firehose URL (or no URL at all?). I can't use the title link to read the story. (Note: the "many more" button or the scroll-to-the-bottom-to-get-more-articles javascript both insert the correct URL for articles it adds to the screen)

2) If the article has "related articles" sometimes a related articles box appears in the firehose instead of the read more link, but the related articles boxes do not appear at all on the index. Combined with the incorrect title link in 1, these articles are impossible to get to from the firehose. Currently, the idle article about the burglar on facebook is mangled this way in the firehose.

A Journal Message Bug? (1)

damn_registrars (1103043) | about 5 years ago | (#29484407)

CmdrTaco-

I have my message settings set to send me a message anytime a friend posts a journal entry. I have you on my friends list, however I received no message when you posted this journal entry.

Re:A Journal Message Bug? (2)

CmdrTaco (1) | about 5 years ago | (#29492481)

Added to the bug list.
Check for New Comments
Slashdot Login

Need an Account?

Forgot your password?