Beta

Slashdot: News for Nerds

×

Welcome to the Slashdot Beta site -- learn more here. Use the link in the footer or click here to return to the Classic version of Slashdot.

Thank you!

Before you choose to head back to the Classic look of the site, we'd appreciate it if you share your thoughts on the Beta; your feedback is what drives our ongoing development.

Beta is different and we value you taking the time to try it out. Please take a look at the changes we've made in Beta and  learn more about it. Thanks for reading, and for making the site better!

My experiences with XPDE (v 0.4.0)

Punk Walrus (582794) writes | more than 10 years ago

User Journal 0

I thought I'd give this GUI a try, since I have been curious about it, and I had a spare machine to run it on in case I fouled it all up. Basic summary is this is very unfinished and needs work, but since it's a beta, that's to be expected, although I would more than likely call this an Alpha-type release than anything else. Usually betas have most of the features installed. I will be truthful, but not overly critical. This machine was a Red Hat 9 box withI thought I'd give this GUI a try, since I have been curious about it, and I had a spare machine to run it on in case I fouled it all up. Basic summary is this is very unfinished and needs work, but since it's a beta, that's to be expected, although I would more than likely call this an Alpha-type release than anything else. Usually betas have most of the features installed. I will be truthful, but not overly critical. This machine was a Red Hat 9 box with a small Intel 8mb VGA chip.

I downloaded the full version (with libs), unpacked it, and followed the INSTALL instructions to a T. I made no assumptions. The install directions are very basic, and easy to follow, so no problems there.

I logged on as a normal user, and chose xpde as my GUI off of GDM. The first time, I got an error (MS-like) in blocky-jaggy fonts that stated it could not find /opt/themes/something...something.png. I clicked "OK" and got 1/3rd of the center of my screen with nothing but my default Redhat blue background and a taskbar. I couldn't click anything on the menu but "logout," so I did.

I tried again, expecting the same. But I got a different response! This time, I got the same error, but the desktop background was the picture of a meadow. The taskbar was still in the center of the screen, but now I could click on other stuff. I clicked on "Control panel" and the GUI crashed, putting be right back to GDM. Hmmm...

So I tried again. This time, the title bar was properly rendered at the bottom of my 1028 x 768 screen, with the green meadows desktop background. I could click on anything with no crashing.

The feel is very WindowsXP with "classic desktop," but with an added "HOME" link on the desktop. Here's what I found while poking about.

Clicking on HOME and MY DOCUMENTS produces an Explorer-like interface. I say "like" because the icons are all generic grey boxes with a blue stripe on the top. MY COMPUTER does not show the correct hardware on the system. It has a FLOPPY drive, even though this machine does not have one. When I click on it, it shows nothing. I don't know where it goes, because I cannot right-click and do a "New" anything (it's not even a choice). I have no /mnt/floppy.... so where's it getting it? Same with CDROM. When I write a file in /mnt/cdrom, it shows up in the explorer, which does not dynamically update, I might add; you have to close it and reopen it to refresh, and even that's not a sure thing... there is no "refresh" from the dropdown menu, and F5 does not work. Only closing and re-launching explorer works.

Right clicking anything, and selecting "properties" does nothing. Half the dropdown menus in the Explorer also do nothing. Double clicking on application shortcuts do not launch items except Calculator, Notepad, Command prompt (generic Xterm), and File Explorer.

The fonts are old style KDE mini-jaggy everywhere: dropdown menus, file listings, taskbar, everywhere. Even the icons look like bad closeups. Sometimes the desktop would not refresh, and I'd get blue icon shadows until I right-clicked and hit "refresh."

Right clicking desktop brings up the desktop menu. There seems to be no "themes" to select from. I was able to change the desktop wallpaper, but only from jpegs. Everything else (Screensaver, Appearance, Display) did not work that I could see. Arranging icons did nothing, but I was able to make a working shortcut (I used xeyes) on the desktop. Then I tried Mozilla, and while the XPDE shortcut did nothing, my shortcut launched it successfully. I has able to right click, and change the properties (I changed the icon to a jaggy Mozilla-ish icon). I cannot lasso multiple icons, I can only move one at a time.

After browsing the web a little, when I clicked on a site that launched a new window, the GUI froze, and froze HARD. CNTL+ALT+DEL did nothing. CNTL+ALT+BACKSPACE got me back to GDM, and when I logged back in, all my previous settings were still there. I was unable to reproduce this, so this may have been a Mozilla thing.

The Network Neighborhood did have the ability to add some info about the network, but it wouldn't let me add a WINS server, and couldn't see anything in my Workgroup, although it listed it. When I added my username and password, it showed my username as a machine on the network. Needless to say, clicking on it did nothing.

The control panel icons launch, but not much can be changed. I was unable to change even the most basic of things, like keyboard rate, double-click speed, etc...

My summary of this is that while it has a look of WinXP, the feel has a loooooong way to go. If this were XP, I would have assumed the registry was corrupted beyond repair, and done a full reinstall. But this is a beta, and they have acknowledged at least half these issues as far as I can see. So this will be a waiting game to see if they are able to get the look AND feel of Windows... in my lifetime. I would hope this continues to develop, because this GUI has a lot of protential for easing users into Linux.

Meanwhile, I'll stick with the good old KDE and terminal windows.

cancel ×

0 comments

Check for New Comments
Slashdot Account

Need an Account?

Forgot your password?

Don't worry, we never post anything without your permission.

Submission Text Formatting Tips

We support a small subset of HTML, namely these tags:

  • b
  • i
  • p
  • br
  • a
  • ol
  • ul
  • li
  • dl
  • dt
  • dd
  • em
  • strong
  • tt
  • blockquote
  • div
  • quote
  • ecode

"ecode" can be used for code snippets, for example:

<ecode>    while(1) { do_something(); } </ecode>
Create a Slashdot Account

Loading...